Back
Degraded

Trouble logging in

Started 30 Sep at 04:20pm CEST, last updated 30 Sep at 07:37pm CEST.

Authentication API
Updated

Customers using our Ruby on Rails agent v6+ were still encountering issue while logging in. This was related related to a Ruby dependency called httpclient (issue can be found here - https://github.com/nahi/httpclient/issues/445).

Please upgrade to the latest version of the major you are using; v6.6.3 or v7.2.2 to fix the Ruby on Rails agent issue.

Posted 30 Sep at 07:37pm CEST.
Resolved

We encountered an issue with our authentication system. It got fixed, but action is now required on your side to ensure continuity.

More info can be found here: https://community.forestadmin.com/t/sept-30-trouble-logging-in/3381

We want you to know that we’re working internally to prevent similar issues in the future and are deeply sorry for the inconvenience.

Posted 30 Sep at 05:42pm CEST.
Updated

This problem affects projects using Node.js agents v7+ and Ruby on Rails agents v6+. To resolve this issue,

- Customers not using a static FOREST_CLIENT_ID need to restart their server to log in back to Forest Admin.

- Customers using a static FOREST_CLIENT_ID will need to regenerate it on all environments and restart their servers.

To generate a new FOREST_CLIENT_ID, run the following command in a terminal:

curl -H "Content-Type: application/json" \
-H "Authorization: Bearer FOREST_ENV_SECRET" \
-X POST \
-d '{"token_endpoint_auth_method": "none", "redirect_uris": ["APPLICATION_URL/forest/authentication/callback"]}' \
https://api.forestadmin.com/oidc/reg

(Please replace the FOREST_ENV_SECRET and APPLICATION_URL by your own project values)

Posted 30 Sep at 04:56pm CEST.
Updated

We have identified the root of the issue and are working on a fix. Thank you for your patience!

Posted 30 Sep at 04:39pm CEST.
Created

We're encountering an issue with our application currently SSL certificate. Some users may be experiencing trouble when logging in to Forest Admin. Our engineering team is working to identify the root cause and fix the issue. We apologize for any inconvenience and we'll keep you updated on the status.

Posted 30 Sep at 04:20pm CEST.